Wednesday, November 21, 2007

Running Sugar on Ubuntu Gutsy

OK, I've tried this out, and it works pretty well. To install Sugar, essentially a virtual XO, on Ubuntu Gutsy, do this:

  1. Add (using an terminal/editor or Synaptic) deb http://ppa.launchpad.net/jani/ubuntu gutsy main universe
    deb-src http://ppa.launchpad.net/jani/ubuntu gutsy main universe

    to your /etc/apt/sources.list.
  2. Do sudo apt-get update or the equivalent in Synaptic.
  3. Do sudo apt-get install sugar-emulator sugar-activities.
  4. Enter sugar-emulator in a terminal.

It works pretty well. The window is too big for my small laptop screen, and I'm not sure how to adjust that, but it is fine on my desktop. One notable omission is eToys. There are a number of activities I haven't seen before that are branded by MamaMedia. Not sure what's up with that; I don't really care as long as it is free software. Not sure what activities are going to be on the shipping laptop.

10 comments:

Alejandro Moreno said...

There are some interesting comments (including instructions for changing sugar-emulator's resolution) on this OLPC wiki page: Sugar with sugar-jhbuild

Hugh said...

Fantastic! These instructions work great. Once I changed the resolution I could experience Sugar. Thanks for this. Saved a lot of headaches. On the Wiki it sounds really complicated to get an emulation working.

I'm not sure all the applications will look correct at a lower resolution though. I installed Sim City and it didn't fit into 800x600.

cosmo said...

im attempting this on my ubuntu computer but when i enter "sudo apt-get install sugar-emulator sugar-activities"

i get Reading package lists... Done
Building dependency tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
sugar-activities: Depends: sugar-read-activity but it is not going to be installed
Depends: sugar-write-activity but it is not going to be installed
Depends: sugar-newsreader-activity but it is not going to be installed
Depends: sugar-calculate-activity but it is not going to be installed
Depends: sugar-memorize-activity but it is not going to be installed
Depends: sugar-turtleart-activity but it is not going to be installed
Depends: sugar-chat-activity but it is not going to be installed
Depends: sugar-connect-activity but it is not going to be installed
Depends: sugar-web-activity but it is not going to be installed
Depends: sugar-measure-activity but it is not going to be installed
Depends: sugar-record-activity but it is not going to be installed
Depends: sugar-pippy-activity but it is not going to be installed
Depends: sugar-paint-activity but it is not going to be installed
Depends: sugar-analyze-activity but it is not going to be installed
Depends: sugar-logviewer-activity but it is not going to be installed
Depends: sugar-pollbuilder-activity but it is not going to be installed
Depends: sugar-terminal-activity but it is not going to be installed
Depends: sugar-flipsticks-activity but it is not going to be installed
Depends: sugar-sliderpuzzle-activity but it is not going to be installed
Depends: sugar-jigsawpuzzle-activity but it is not going to be installed
sugar-emulator: Depends: sugar but it is not going to be installed
E: Broken packages"

as a response.

any ideas?

~Cosmo

Tom Hoffman said...

cosmo,
Yeah, that's pretty ugly. It is possible that the packages are temporarily broken, or perhaps your package database is fubar.

cosmo said...

Oh, i feel like an idiot for this typo, but im running EDUbuntu, not Ubuntu. could that be causing the problem?

greywulf said...

This works great! It's fast, stable and much better than fiddling with the jhbuild. I can use Sugar as a standard window manager on my Ubuntu Gutsy system - perfect for my kids :)

I've just the one problem, though it's quite a biggie. The Web activity doesn't start and the log reports that "get_activity_root" isn't a part of the module. I suspect that's because of a recent change to the activity.py code in the core.

Any chance this'll be fixed in the packages Real Soon?

Tom Hoffman said...

I should note here that I didn't do much with this beyond firing it up and playing with it for 10 minutes, so I'm not really much use in troubleshooting. I'm just patiently waiting for my pair of XO's to arrive at this point...

cosmo said...

Okay. Thank you for the instructions. i guess ill just have to wait until mine shows up to try out sugar.

Tudor said...

Hi,
One also has to install python-gst0.10 through apt.

Karin Dalziel said...

I am having the same problem as cosmo- weird thing, the emulator worked fine on Ubuntu on my Dell, but not on my Gateway laptop. Here's the error:

----------------------------------------
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
sugar: Depends: libpango1.0-0 (>= 1.18.3) but 1.18.2-0ubuntu1 is to be installed
Depends: sugar-artwork but it is not going to be installed
sugar-activities: Depends: sugar-newsreader-activity but it is not going to be installed
Depends: sugar-web-activity but it is not going to be installed
E: Broken packages
--------------------------------------

Any ideas? I'd like to get the emulator working for a presentation I'm going to do on the OLPC. :/